Troubleshooting

The LED ring on Themo is blinking RED, what does it mean?
Themo does not have internet connection. Fix: Make sure that there is internet connection to where Themo is connected to. If there is internet connec...
Thu, 28 Jun, 2018 at 6:34 PM
The LED ring has turned to WHITE, what does it mean?
Themo has lost the connection to SLS servers. If the problem continues more than 24 hours, contact support.
Thu, 28 Jun, 2018 at 6:34 PM
How can I restart the Smart Thermostat?
From your circuit breaker box, turn off the fuse that controls your heating for 10 seconds.
Thu, 28 Jun, 2018 at 6:35 PM
Themo LED circle is pink and the lights are moving in circle.
Themo is restarting. If this will continue more that 2 minutes, restart Themo from circuit breaker (see how) If that does not help, contact support.
Thu, 28 Jun, 2018 at 6:46 PM
How can I control my heating system when the Wifi connection between the Smart Thermostat and the router is lost?
To reconnect Themo, see instructions here. If you do not have WiFi connection, you can control Themo from your front panel. Please see Themo Welcome Gui...
Thu, 28 Jun, 2018 at 6:41 PM
I have Themo installed and the app shows offline. What does it mean and what can be done?
Themo does not have internet connection. See instructions here. Themo does not have established connection with SLS servers. See information here. Restar...
Mon, 3 Dec, 2018 at 11:25 PM
I think that the real power consumption is higher / lower than Themo is showing, what can I do?
Themo has built in capabilities to measure power level of your underfloor heating. The internal measurement has 10% margin of error. In case of very low pow...
Wed, 11 Sep, 2019 at 7:26 PM
Why is Themo heating during expensive time?
There can be many reasons: Themo is in Manual mode, not SLS mode Themo machine learning period is approximately 1 week and during that time it can overhe...
Thu, 28 Jun, 2018 at 6:48 PM
The temperature measurement of Themo is not quite right, what does it mean and how to change this?
Themo is shipped with 10k Ohm temperature sensor and whenever possible this sensor should be used. The correct sensor is selected during Configure and Setup...
Thu, 28 Jun, 2018 at 6:44 PM
Themo button does not work.
Hold down the Themo button for 10 seconds to see if button lock was enabled. Restart Themo (see here) If the problem continues, contact support.
Thu, 28 Jun, 2018 at 6:48 PM