I have Themo installed and the app shows disconnected. What does it mean and what can be done?

Created by Themo Support, Modified on Sat, 13 Jan 2024 at 03:43 PM by Themo Support

Encountering issues with your Themo device appearing disconnected/offline on the mobile app? Various factors could contribute to this problem. Here's a step-by-step guide to help you address unexpected disconnections.


When Themo loses connection to the Wi-Fi router, the LED ring will blink WHITE (some versions may blink RED).





If you have previously connected and operated your device, there are several other reasons why the app could now be showing device disconnected. Here are a few ways in which you can solve the problem:

  1. Ensure there is an internet connection where Themo is located:

    • Check if other devices in the same location have a stable internet connection. If not, please check that your router is powered and reset the router. This will usually resolve a temporary issue with the internet connection.
    • Ensure that Themo is within the range of your Wi-Fi network. In order to improve Wi-Fi coverage make sure your router is in a central location, elevated off the floor, away from walls, obstructions and other electronics.
  2. If the internet connection is working, make sure that power is available to your device.

    • Touch the mode button to check the lights. If lights were previously switched off from the app, they will appear for 1s when mode button is touched.

    • If the lights did not turn on, check if the power is on!

  3. If power is available to the device then try restarting your device from the circuit breaker box:

    • Locate the circuit breaker box.

    • Identify the switch corresponding to Themo and turn it off. This effectively cuts off the power supply to your device.
    • Wait for about 10 seconds before turning it back on.
    • Turn on the switch corresponding to Themo to restore power.
    • Themo will start up and attempt to reconnect to the Wi-Fi network.
    • After restarting the device it may take Themo a few minutes to connect to our servers. Themo will show white lights when connection to the server is not yet established.


If you are currently setting up your device, please make sure you have provided your home Wi-Fi name and password. 


If you can’t resolve your problem immediately or if there is no connection, you can always control your heating manually on your devices.


If the issue persists after following these steps, please contact our support team for further assistance at support@themo.io.


More information:









Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article